FROM CACHE - zh-cn_header

Facebook渠道如何为应用安装最新版 Facebook SDK?

Hipa-Heidi
访客
1 0 0
有没有大神知道如何为应用安装最新版 Facebook SDK?
Facebook后台提示需要根据指示使用 Cocoapods 或 SPM 更新,但没有网站服务器权限的情况下,还有没有其他方法可以更新Facebook SDK呢?求大神有空帮忙解答,不甚感激!!
 
1. 更新 iOS 版 Facebook SDK
根据指示使用 Cocoapods 或 SPM 更新。
 

第 1 步:更新 iOS 版 Facebook SDK


使用 Cocoapods
如果您的应用使用 Cocoapods 与 iOS 版 Facebook SDK 集成,请按照以下步骤操作。

1.将代码添加到应用中使用的软件包的 podfile 中。

示例:

 

pod 'FBSDKCoreKit', '~> 8.0.0'
pod 'FBSDKLoginKit', '~> 8.0.0'
pod 'FBSDKShareKit', '~> 8.0.0'
pod 'FBSDKGamingServiceKit', '~> 8.0.0'

2.运行 pod update


使用 Swift Package Manager (SPM)
如果您的应用使用 SPM 与 iOS 版 Facebook SDK 集成,请按照以下步骤操作。

1.在 Xcode 中,点击 File(文件)> Swift Packages(Swift 软件包)> Add Package Dependency(添加软件包依赖项)

2.在 Package Repository(软件包存储库)中,输入存储库网址:https://github.com/facebook/facebook-ios-sdk

3.在 Version(版本)中,选择 Up to Next Major(直到下一个重大版本),然后选择默认选项。

4.完成提示,选择要在项目中使用的库。

0 条回复0