ローカル開発にて theme watchで警告が出る

解決済
Highlighted
観光客
10 1 2

theme kitにて ローカルで開発中のテーマ 

 

theme openに対してはいつも通り反映するのですが theme watchに対して以下のような警告となります。

 

 

5B3EE8F3-6E2E-49F9-A62F-D3D486F3BD2D_4_5005_c.jpeg

「ライブテーマです。

コレに変更を加えたい場合は --allow-liveフラグを渡してください。

オーバーライドなしではライブテーマに変更を加える事ができません。」

 

昨日まで普通にアップ出来ていたのですが、どのような原因が考えられるでしょうか?

0 件の「いいね!」
Highlighted
観光客
10 1 2

すみません、解決しました。

https://shopify.github.io/themekit/commands/ より

 

D0572C3A-7025-4290-B630-B185FDB84C01.png

 

 

何故コレが必要になったかは不明のままです。

 

0 件の「いいね!」
Highlighted
開拓者
88 24 91

成功

ご参考までにという程度ですが、--allow-liveフラッグに関しましては以下のページやページ内にあるリンクを辿ることで理由や概要を把握できるかと思います。

https://github.com/Shopify/themekit/pull/739

私自身はtheme kit v1.1.1にアップデートした際に気がつきましたので、恐らくお手元のローカルでtheme kitをアップデートされたのではと。

1 件の「いいね!」
Highlighted
観光客
10 1 2

成功

jizoさん、ありがとうございます。

 

確かについ先日アップデートしました。

 

参考ページをよく見て勉強させてもらいます。

1 件の「いいね!」
Highlighted
Community Manager
Community Manager
527 118 194

本番利用されているテーマの直接変更には、表示されている通り、それを許可するフラグが必要かと思います。

https://shopify.github.io/themekit/commands/

Technical Partner Manager, Japan
0 件の「いいね!」