キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

最新のDebutテーマでカート追加のポップアップが表示されない

解決済
遊覧客
16 2 5

お世話になります。
立て続けに2件失礼いたします。

 

現在運用中のサイトを最新のDebutテーマにアップデートしようとしているのですが、
「カートに追加ボタン」を押してもロードアイコンがぐるぐると回り続けてポップアップが表示されません。

 

アプリも止めて、一旦テーマをりせっとして試してみたのですがやはりうまく動作しません。

 

コンソールを見ると「Uncaught TypeError: this.$cartPopupWrapper.prepareTransition is not a function」という表示が出ます。

 

error.png

 

もう1つ別のサイトも運用しているのですが、そちらでは問題なく動いてます。

 

以前もあったんですが、アプリやテーマなど同じ環境で利用しているのに、1方のサイトが上手く動かないことが時々あります。

アカウントごとにシステムが異なるのが原因なんでしょうか??

 

どなたか原因と解決策が分かる方いらっしゃいましたら、教えていただけると幸いです。

0 件の「いいね!」
Highlighted
Community Manager
Community Manager
178 37 59

アカウントごとにシステムが異なることはありませんが、商品などのデータが異なる関係で挙動が異なることはあり得ます。

ちなみにご自身でカスタマイズなどはされていますでしょうか?

Technical Partner Manager, Japan
1 件の「いいね!」
Highlighted

成功

遊覧客
16 2 5

 

 

0 件の「いいね!」
Highlighted

成功

Community Manager
Community Manager
178 37 59

>ちなみに、カスタマイズやアプリなどを利用していないまっさらな状態のテーマを適用しても、
同じエラーがおきます。。。

 

アプリをご利用になられている場合は、テーマ本体以外の影響も考えれますが、例えば、

エラーが起きてるテーマをダウンロードして、他のストア(新規に作った開発ストアでも良いと思います)にアップロードしてみるのはいかがでしょうか?

 

アップロードする前に新規にストアに最新のDebutを入れて挙動を確認してからやるとなおよいと思います。

 

コンソールをみる限り、theme.js内で呼んでいるfunctionがundefinedになっているようなので、読み込んでいるライブラリのバージョンの問題の気もします。

 

そこで同じエラーが起きるのであれば、テーマファイルのどこかに問題があり、起きない場合は、テーマ以外の部分に原因があるかと思います。

 

 

Technical Partner Manager, Japan
1 件の「いいね!」
Highlighted
遊覧客
16 2 5

コメントありがとうございます。

 

>例えば、エラーが起きてるテーマをダウンロードして、他のストア(新規に作った開発ストアでも良いと思います)にアップロードしてみるのはいかがでしょうか?

 

なるほど。。。その手がありましたね!!

 

ということで早速試してみたのですが、他のストアの方ではエラーが出ませんでした。
となると、やはりテーマではなくアプリが悪さしてるのかもしれませんね。。。

 

【バックエンド アプリ】

Custom CssOrder Printer

Order Printer Templates

Uchuya Shipping Cooperation

 

【フロントエンドアプリ】

Page Speed Optimizer by Booster Apps

Smart Image SEOStamped.io Reviews & UGC

 

フロントエンドのアプリが怪しかったのでインストールしていないテーマでプレビューを試したのですが、やはり不具合が出るようです。

 

となると、、、バックエンドアプリかもしれませんね。

引き続き原因の調査を進めてまいります。

0 件の「いいね!」
Highlighted
遊覧客
16 2 5

本件、解決しました!

 

「Uchuya Shipping Cooperation」アプリが不具合をおこしていたようです。

以下、解決方法▼

 

  1. 「Uchuya Shipping Cooperation」アプリを一度削除
  2. 再度、アプリを追加

以上で難なく解決しました。


原因として、削除前にアプリのJSが読み込まれていたらしく、
どうもこれが干渉をしていたようです。

 

削除して再インストールしたところ、JSが消えて挙動が正常になりました。

なぜなのかは全く分かりませんが…

 

解決したで良しとします。

 

コメントしていただいた皆様ありがとうございました!

1 件の「いいね!」