FROM CACHE - jp_header

gem update shopify-clい でアップデートできないです。

解決済

gem update shopify-clい でアップデートできないです。

mk777
探検家
52 13 2

私は、Ubuntu18.04LTSで、 shopify-cliをインストールしました。

1.4ですが、バージョンアップ必要と表示がありました。

 

ubuntuの手順で、下記のエラーが出てインストールできないです。

 

ERROR:  Error installing shopify-cli:
	shopify-cli-2.15.6 requires Ruby version >= 2.6. The current ruby version is 2.5.1.p57.
dpkg: アーカイブ /home/kumazaki/ダウンロード/shopify-cli-2.15.6.deb の処理中にエラーが発生しました (--unpack):
 new shopify-cli package pre-installation script subprocess returned error exit status 1
処理中にエラーが発生しました:
 /home/***/***/shopify-cli-2.15.6.deb

 

 

今のversionは、

shopify version1.14.0

 です。

 

Rubyのversionは、次の通りです。

ruby -vruby 2.6.10p210 (2022-04-12 revision 67958) [x86_64-linux]

 rbenv versions
  system
  2.6.0* 2.6.10 (set by /home/***i/***/shopify_theme/.ruby-version)
  3.1.2
1 件の受理された解決策

mk777
探検家
52 13 2

成功

自己解決しました。

rubyのバージョンを上げて2.7.6にしてから、 shopify-cliをインストールしたら新しいバージョンをインストールできました。

 

元の投稿で解決策を見る

1件の返信1

mk777
探検家
52 13 2

成功

自己解決しました。

rubyのバージョンを上げて2.7.6にしてから、 shopify-cliをインストールしたら新しいバージョンをインストールできました。