Entering Google Product Categories in Shopify

Solved
usernamesrule
New Member
2 1 0

This is an accepted solution.

Hi Tira, we are experiencing the same thing as @VTBVTV

It is painfully frustrating. We've been working on this issue and trying to figure it out for 3-4 months. We currently have 432 products than are not publishing to google. Here's a quick example... in the screenshot below, you can see the product is not published to google because it says it's missing the age group, color, and gender. When I click the drop down menu under more actions you can see that all of those 'missing values' are in fact there. Why does it keep saying they're missing?!

We have tried all of the tricks to get this to work. We've tried using more general categories, and more specific categories. We've tried filled out all of the optional fields. We've deleted all the info, saved the product, and then added the info back in, and saved the product. This last method sometimes works and makes the error message go away, but its only temporary. Without fail, after 20 min - 48hrs, the product reverts and the google dot goes back to orange rather than green, as you can see in the screenshot below.

Screen Shot 2021-04-08 at 2.09.03 AM.png

Here is another example, I believe the screenshot below shows what @VTBVTVis seeing as well...

You'll see on the right side of the screenshot that the product wont publish to Facebook because it needs a google category (even though the product has a google category) and then it says its not publishing to google because the product needs a gtin - which it doesn't because it is a custom product with the google category info completed. 

Screen Shot 2021-04-08 at 2.22.57 AM.png

And then here's one more example - which is a little more rare than the others... this product made it through and is published to google, however its not publishing to facebook, saying it needs a google category, even though it has a google category!! 

Screen Shot 2021-04-08 at 2.21.29 AM.png

Thank you in advance! 

0 Likes
usernamesrule
New Member
2 1 0

@Tira (meant to tag you in my post above)

0 Likes
Tira
Shopify Staff
Shopify Staff
1001 61 164

Hey, @usernamesrule

Thanks for joining the thread and I really appreciate the time and effort you took to troubleshoot this and the details you’ve provided. It sounds like you’ve been working on this for a while and I’m here to help. 

I dug into this with our technical team and after updates are made to a product, it can take up to 24 hours for changes to take effect. It sounds like changes are being made, but these errors are still showing for you after. I recommend trying to remove the products from the Google Channel for a few hours, and then re-adding the products again. 

To do this, you can follow these steps:

  • From your Shopify admin, go to Products > All products.
  • Click the product's name to open its details. The product is available to the sales channels listed in the Product status section.
  • Click Manage.
  • Select the Google Channel to remove the product from that channel
  • Click Done.
  • Click Save.

Once a few hours have passed, you can go back to the product and make it available on the Google Sales channel with the steps from this help doc: making products available on sales channels. As you have a lot of products, I recommend using the bulk editor to perform bulk actions for several products at once.

I also looked into the error with your custom product showing that a MPN/GITN number is missing. If the product is a custom product, then this is likely a display error. Our developers are aware of this and are working with Google to resolve this issue. 

I would love to know if this helps.

Tira | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes