Google Analytics not tracking eCommerce data but appears to be set up correctly

lintriago
Excursionist
17 0 7

Google Analytics has been set up in Shopify since before I even launched my site.  I often monitor in real time and it's capturing data fine except not transactions.  I turned it on in View/Ecommerce.  The Use Enhanced eCommerce checkbox is checked in Shopify.  I cannot for the life of me figure out why I am not seeing transactions coming through.  Has anyone experienced anything similar and can offer insight?

 

lintriago_0-1602688233910.png

 

0 Likes

Do you have other visitor data coming through?

Do you have Enhanced Ecommerce checked within the Online Store preferences of your Shopify admin?

They're two fundamental checks.

On top of that, without knowing anything else from you shared, what is the store? Seeing it would help. Another source of help is my analytics guide for Shopify. Many merchants have used it to setup Enhanced Ecommerce and a lot more for their store.

Run Google Shopping ads? Get the free definitive guide to Google Shopping for Shopify (no optin required): https://www.digitaldarts.com.au/google-shopping
0 Likes
lintriago
Excursionist
17 0 7

Well, yeah... that's why I included a screenshot and details that I had followed directions explicitely.

It is fixed now and I figured it out on my own.  FYI to anyone having same issue:

I set up Google Analytics even before the site launched.  Payment section had yet to be set up. but visitor data was tracking correctly as I had given certain people the password to access the staging site.  Then just before removing password and launching my store, I set up payment and toggled enhanced ecomm in GA. I did tests, had real transactions and nothing was tracking in the eComm section of GA.  Then I recopied/pasted the tag from GA.  I noticed that upon toggling enhanced eComm in GA, the tag modified.  I needed to update the code in Shopify to start tracking transactions... Once I did that, all was well....

Having some problems with the same as well, and getting this notifications in GA: "View Default is configured for Ecommerce, but no data is flowing." Some goals record transactions, and some don't. Also not seeing $$$ value on the goals. 

Had to check if the tracking ID changed when I toggled enhanced reporting on/off, but it didn't. 

0 Likes