Pinterest blog link landing on homepage

Philip_Ó_Condúi
Tourist
4 0 1

Hi All,

Im having an issue with pinterest.  

When I pin my blog post on my board in pinterest it works fine.

But when I click on the pin in pinterest it takes me to my website home page rather than to the actual blog post.

Can anyone point me in the right direction to figure out why this is happening. 

Regards,

Phil

0 Likes
Philip_Ó_Condúi
Tourist
4 0 1

I think it might have something to do with the time it takes to make a change on the shopify servers.

It worked after a little while.  Now i have enabled the password on my site again.

0 Likes
Sara_M2
Shopify Staff
Shopify Staff
16 0 3

Hey Philip!

I just tested this with my own site and the link worked instantly for me. How was it that you had shared the link? Was it directly through a button on your shop, through a browser extension, or manually through the Pinterest site directly? I'd like to try to replicate your steps exactly to see where a delay might be happening. When I tried, it was through the Pinterest site directly.

I'm gad to hear that it will work for you eventually, but we want to make sure that there's nothing getting in the way on the Shopify side of things. Any details that you have on your steps will help us see what might be happening here.

Chat with you soon!

Sara

0 Likes
Philip_Ó_Condúi
Tourist
4 0 1

Hi Sara,

First Test:

  • Store password protected.
  • My blog was pinned using chrome extension
  • Board on pinterest was private.

Result:

  • When i clicked on the link from pinterest it took me to the password page on my site.
  • Waited a few minutes and the link from pinterest took me past the login page and landed on my front page

So I removed all the restrictions, removed the password on my site, created a public board on pinterest and repinned using the chrome extension.

Results were the same with the only difference being the link was not hitting the password page.

  • All links just landed on my home page not the blog page
  • After about 5-10 minutes the links on pinterest stated working and landed on the blog page.

I thought it might have been a problem with my domain settings but these were correct.

To be honest I think it might be a problem with Pinterest.  The servers seem a bit slow updating stuff in general so maybe its just taking time to update.  On the otherhand it could be my cache settings messing it up.

Regards,

Phil

 

 

 

0 Likes