Pixel Not Tracking Some Events

Solved
thevisualtailor
New Member
4 0 0

Hi there,

I'm having some trouble with data not being collected in regards to my site. I've had purchases, but data seems to be missing for the events below (images attached).

The weird thing is when I test the events in the browser using the Facebook Pixel Helper, they show as correct from what I can tell - you can check at thevisualtailor.com.

Any ideas on these would be great! You can read some extra content below that may be relevant.

Thanks,

Jay

Additional Context

- This could be nothing, but I changed themes a few weeks ago. I was previously running Buy Buttons on a Squarespace equivalent CMS. Now I'm on a complete Shopify theme.

I've made this change to track more steps in my funnel as the CMS Buy Buttons only followed ATC onwards. So far, no luck, haha.

- Also, I went to my premium theme's developers to ask if they were experienced in these issues on their theme. They took a look, and the only problem they could work out was the add to cart event was being triggered twice. They resolved this in my theme.

 

 

 

Events showing no activityEvents showing no activityactivity details for AddPayment infoactivity details for AddPayment infoactivity details for Add To Cart infoactivity details for Add To Cart infoactivity details for Search infoactivity details for Search info

0 Likes

Hi @thevisualtailor

Not sure if you've heard a bout it, but in cases where troubleshooting can take up much of your time and it's hard to pinpoint what's wrong, I'd recommend you try Pixel Set Up Tool. 

Basically, it helps you add pixels to your website without the need for custom code

Learn more about it here: https://www.facebook.com/business/help/777099232674791?id=1205376682832142

Let me know if my answer is of any help with a thumb up or like Cheers

PageFly - Advanced Shopify Page Builder - Empowering 90.000+ active merchants.
Survive 2021 with top secrets from e-commerce leaders
PetrusB22
Shopify Partner
40 6 3

This is an accepted solution.

Hi,

it might be similar to a problem that I recently encountered. Have a look at your allowed/blocked domains inside your Facebook event manager. It might be blocking your domain or part of your domain.

0 Likes
thevisualtailor
New Member
4 0 0

@PageFly Thanks for the feedback. I'm not sure this is quite what I'm after here, though. The majority of my funnel events are tracking as expected; it's just a couple that seems to have stopped for no reason.

I don't want to risk installing from scratch if it interferes with my current campaigns.

0 Likes
thevisualtailor
New Member
4 0 0

Thanks @PetrusB22 - I've checked and it seems there's nothing listed in my blocked domains, unfortunately. Would have been a nice quick win!

0 Likes
thevisualtailor
New Member
4 0 0

@PetrusB22 You were correct!! It turns out that my own domain was blocked inside the pixel settings! Thanks for the suggestion

0 Likes