"Product identifiers provided but 'identifier_exists' set to false."

Highlighted
Tourist
35 0 2

Hi, I have been trying to get our Google product feed working for quite some time now. I had no luck with the Google shopping app and we have now switched to using Retail Tower to manage our feed. We generated a feed and submitted our feed to the Google merchant center. But its seems almost all of our items have the error "Product identifiers provided but 'identifier_exists' set to false." I believe this is used if your products don't have identifiers, but our products do have identifiers.

The problem is I can find no place in Shopify or Retail tower to change this attribute. In fact I don't find that attribute anywhere. Is there a way to set all product to true? This is extremely confusing to me.

Any help or clarification on this would be helpful.

 

Thanks

0 Likes
Highlighted
Excursionist
14 0 4

Sorry I can't answer your question but as a quick fix, you may be able export your feed from Shopify or Retail Tower (not sure if they support that) as a .csv file and edit that field in excel (or similar) - then re-upload it to Google MC. 

The feed will be good for 30 days if you set he expiry date accordingly, so you won't have to do this daily! Unless of course you are adding a lot of products!

If you can't get the feed from either source, GMC has a link to download the feed you submitted.

Hope that helps?

0 Likes
Highlighted
Tourist
35 0 2

Thanks for your reply, I've made some headway since I posted this thread, so I may be on my way to figuring the whole the out. There is just very little documentation or explanation of any of this stuff, so sometimes its difficult to sort out. It doesn't help that we had web developers working for us that apparently were clueless. But yeah thank you for the suggestion. For anyone looking in the future, the setting to use or not use the product identifiers is in the Google shopping app for Shopify under settings. Don't ask me why it took me so long to find it, but I'm glad I finally did... 

0 Likes
Highlighted
New Member
1 0 1

Hi, I am getting a similar issue with Merchant Center for (Incorrect value [identifier exists]) as you have suggested I did try to find the setting to fix this under the Google Shopping app in Shopify but it was not listed there. I would really appreciate it if you can show us the way to fix that. Thanks

1 Like
Highlighted
New Member
2 0 2

I know this is old but it was a pain in the ass and finally found a way to solve it so thought I'd post it here. 

I contacted the support and they said "If your product's are truly custom product they will not require any of those to be added and Google's developers have assured us that this will have no impact on your Google Shopping ad campaigns in that case." It could be a coincidence but my ad wasn't showing and I had set the object to custom. 

But then showed soon after I set the "identifier exists" to false

 

In google merchant under feeds I added a supplemental feed. I used the google sheet option and on the first column heading on my sheet I had "id" and i pasted the shopify ID for each product underneath. On the next column I used "identifier exists" as the heading and put false for each ID i used. Then clicked the fetch button and a short while after it changed the identifier exist value to false on the products 

2 Likes
Highlighted
New Member
1 0 0

 tommyyyy that fixed my issue!!!  I even spoke with Google Merchant tech support and they recommended I to use "false" for GTIN and MPN. Other guides suggested  barcode with "false" Your guide solved it and I removed barcode, GTIN and MPN.  Thank you!!!!!!!!!!

0 Likes