Broken Shipping Method for all products: No Shipping Methods Available

Solved
Christine_Lemke
Tourist
4 1 0

Help!  I recently made some Admin Settings changes to Shipping and Delivery, as well as Locations, plus I'm using the Bespoke Shipping app and had some changes made to it by the developer about the same time.

One of the above events caused my store's Checkout to throw the "There are no shipping methods available for your cart or address" error.  This may have been occurring for about a week or so, but just now noticed it and have spent the last day trying different things to fix it.  (Fortunately, or rather unfortunately (LoL), my store has no sales to speak of at this time, so no financial impact yet...)

This might get TDLR, but missing info may cause delay in finding the root of the problem.  Here goes.

1. On Sept. 18th, I had ordered some of my own products without any problem.

2. On Sept. 26th, I noticed the problem for the first time when I tried to checkout again.  Tried multiple products, same thing.

3. My store uses a POD (Print on Demand) and Dropship vendor, Customcat, and also uses the Bespoke Shipping app to calculate shipping rates.  Customcat uses a Flat Rate shipping model for all Domestic and International shipping and the Bespoke Shipping app was setup to use those rates accordingly.

While checking to see if I needed to update the shipping rates, I saw that Customcat also has distinctions for 4 types of product classifications that affects shipping rates. (E.g., Lightweight, Heavyweight, etc.)  I contacted the developer at Bespoke Shipping and they quickly and easily pushed out an update so I could take into consideration Customcat's 4 types of product classifications for calculating accurate shipping rates and charges.  I only needed to ensure that each product had that info or tag so the app can use it before I "uncomment" a line of code to turn it on in the app.  I never uncommented the line of code, as I need to work on getting the products updated for being Lightweight, Heavyweight, etc.

4. Around this time I decided to check on some settings in the Admin Settings for Shipping and Delivery, as well as Locations.  Originally, there was only one Location and Shipping Origin. It was set to my Store Name using my Home Address since the start of the store. I realized that the Origin (Ship From) is actually Customcat and their address is in Detroit, Michigan, so I edited it to be Customcat's name and address, thinking this is the accurate address to use for any shipping rate calculations.  I then created a second Location for some reason I forget, setting that Location to what I had originally (my store and home address), then for whatever reason, changed the 2nd Location again to match the first location, but Deactivated the Location. (I missed seeing the Delete button, so Deactivated instead.)

5. When I discovered the Checkout problem, I quickly emailed the Bespoke Shipping app developer about the problem and I quickly received a reply!  Here it is:

This sounds like an issue with your Shopify shipping profile, if you have created secondary profiles, you need to manually add Bespoke to all secondary shipping profiles/zones, saving the app in macro editor will cause this to drop off again.

 

As we’ve setup the rates within Bespoke as required, I don’t think you need your shipping profiles in Shopify anymore? (unless you can see a reason why you would need it?) therefore recommend you remove all of the secondary shipping profiles, you still need the default shipping profile, and be sure that the places you ship are still added into a valid zone in that default profile, with Bespoke shipping listed under that zone(s) too.

I went through the documentation, researched Shopify's own community boards, and tried just about everything suggested or looked even remotely possible.  I even removed all Locations and created (1) using Customcat's address, then (2) just only my own home address as it was originally.  Checked all products for "Shipping Required" (all were).  Nothing worked.

I then re-created the Shipping Rates, per Bespoke Shipping's documentation, assigned the app to handle shipping as specified, etc.  Nothing worked.

I am stumped and need assistance to get the store's checkout (for shipping) working again.  I can only think of a few other things to try: 

(1) Ensure that Shopify's Real-time shipping plugin (or also known as Carrier Calculated Shipping or CCS) is still active for my store.  (Bespoke Shipping requires this to work with Shopify checkout.)

(2) NUCLEAR OPTION:  Close the Store down completely and re-create a new store, re-purchase apps, etc.  My problem is not so much the time and effort, but can I get the same domain redirection to MyStoreName.myshopify.com, or will I have to come up with different StoreName.myshopify.com...?

(3) Pray that someone in the community, or from Shopify itself, knows exactly what to do to correct the problem.

0 Likes
Christine_Lemke
Tourist
4 1 0

This is an accepted solution.

Great NEWS !!!

I fixed the problem.  Problem was with the Bespoke Shipping APP.

I had a copy of the original code and put it back, replacing the new code that Bespoke Shipping had provided about the time the problem started.

0 Likes