Check out showing a shipping rate I did't select

Solved
Highlighted
Tourist
4 0 1

Hi there,
I'd like to offer free shipping for all of my products in my store.
All products are synced printful items.
I have only one profile (general profile), only one zone, with shipping rate set to 0. No conditions added.
In test mode, the check out shows "Europe Flat Rate" shipping method, and also charging a rate. No idea where that shipping method is coming from.  (I deleted cache and cookies of my browser twice already)
I also noticed that in the product section, there is a shipping option to check, when creating new products from scratch in the store, but there're no options in the products imported from printful. Does this produce the error?
I'm confused, did anyone have the same problem when new to it?
Would appreciate any advice :)

0 Likes
Highlighted
Shopify Staff
Shopify Staff
155 22 31

This is an accepted solution.

Hi, @Kai_1!

 

Thanks for your question. When you open your Shipping settings, you'll see your General Profile at the top of the page. Based on the information provided, my thinking is that you do have your general profile set up correctly. What I think the issue is, is that you have Printful's shipping rates enabled on top of your own. Underneath the General profile in your Shipping settings you should see an App Shipping Profiles section with Printful listed. If you click into this section, you would see shipping settings and rates that are served by Printful. You'll want to make sure you change these to offer free shipping on your store.

 

Once you've taken a look into this, please let me know if that resolves things here. If not, please let me know and i'd be happy to take a look into this in more detail together.

 

Hope this helps!

 

Oliver | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
Highlighted
Tourist
4 0 1

Hi Oliver, !!Thank you!! for your prompt reply! You are right, now it works!
Sometimes the most complex problems have simple solutions. :D
Thank you, have a good day!
Kai

0 Likes