"Charge Taxes" By default for all products.

19 0 1

The "charge taxes" option is unchecked by default in shopify. I want to charge taxes on all products listed on my website. For this I have to edit the products individually to check the "Charge Taxes" option every time I add a new product to my store. This is getting very hectic as I have 400+ products listed on my site and 10-20 new products are added almost everyday.

I want to know if there is any way the keep the "charge taxes" option checked for all products (existing products in store and new products that are added everyday). If not, is there an easier(less hectic) way to charge taxes?

Also I don't want to include taxes in the product prices.

1 Like
Shopify Staff
Shopify Staff
105 0 17

Hi Siddiqui,

Chris from Shopify here. Your store should be defaulting to having "charge taxes" checked when you add a new product, so that's pretty weird! May I ask which browser you're using? Also, could I get a link to your store please? I'd like to take a look at your admin to see this in action. This may be something worth emailing support@shopify.com about since the default, expected behaviour is not happening. 


Chris D
Shopify Guru

New Member
7 0 0

Close topic to what I need, thank you for asking the question. Is there a sitewide option to *not* charge tax (tax is included with the products) and also a sitewide option so that the "This product requires shipping." is *not* checked?

I did set "All taxes are included in my prices" in the tax settings. I thought this would make the store default to not having to uncheck the tax box for each individual product but not seeming to work that way.

All products in this store are digital downloads so tax is already included and no shipping required.

Thank you,


New Member
2 0 1

Hi Chris D

I'm having the same issue as Siddiqui. All of my items have the "charge taxes on this item" unchecked. Also, the items which have variants do not have the option, so I'm left wondering if taxes are going to be charged or not. I'm importing products from Oberlo.

My tax settings are set on automatically. US only, as I'm based in Massachussetts. I can't find anything out of order, but it's a pain to change all my SKUs manually, not to mention risky.

1) How can I make the "Charge taxes" button on each product page check automatically?

2) Are the items which have variants going to be charged taxes? Even if the option is not there on the product page? 

Thanks for all your help.


1 Like
New Member
1 0 1

Can we get an updated reply to the original question?  This is still an issue and is extremely frustrating...

1 Like
New Member
4 0 0

I am also having a problem with taxes with the minimal theme.  At checkout tax is being charged on shipping but not the product.  Any ideas on how to fix this?

New Member
2 0 1

Has there been any resolution to Siddiqui Ahmed's original question? Mine does the same thing and it is very annoying having to click that charge taxes box on every variant of every item. This really should be done by default! 

New Member
1 0 0

I'm also having this problem I have over 400 products with the tax button unchecked. I really do not want to go through each product to check it. I had my tax section set to charge taxes in my state and assumed that everything was working.

In the past 2 weeks I had a abnormal amount of sales from my own state and none of them were charged taxes, which means that money now has to come out of my own pocket! I need a quick resolution to this please.

New Member
1 0 8

Hey everyone, 
Found a solution.

Sorry the developers haven't gotten back to us. I was having the same problems on my store. Here's a fix for it. It's not automatic, but I still turned over 500 items/variants to "charge taxes" within about 5 minutes.
• Go to "Products" > "All Products"
• Click the top Checkmark Box to "Select All" of your products.
• Then the box "Edit Products" appears. Click on it.
• A long list will show of all your products.
• Click "Add Fields" and select "Charge Taxes"
• Zoom the page ALL THE WAY out by pressing "Ctrl" and "-" (or "Option" and "-" on Mac)
• Select the first "Charge Tax" BOX but NOT the inside the CHECKBOX.
• Scroll all the down to the bottom of the list.
• Hold "Shift" and then click the last BOX (NOT inside the CHECKBOX)
• The entire column should appear to be selected at this point.
• SCROLL BACK UP to the FIRST ONE and click the INSIDE of the CHECKBOX.
• Give it a few moments, but all should end up checkmarked. 
• Click Save and wait for them all to save.
• After they've all saved, go to the next page and repeat. :)

Hope this helps! 

New Member
2 0 1

Also, if you are using Oberlo, you can set it in Oberlo settings so everything you import from Oberlo is set to charge taxes automatically. 

1 Like