520 Origin Error on REST API responses?

Conner
Explorer
46 1 9

Hey all,

Is anyone else receiving 520 Origin Errors responses for the REST API?

Receiving the response below:

<html>
<head><title>520 Origin Error</title></head>
<body bgcolor="white">
<center><h1>520 Origin Error</h1></center>
<hr><center>cloudflare-nginx</center>
</body>
</html>

 

Thanks!

TealAtom
Tourist
3 0 1

Yes, I'm seeing these on the graphql storefront API, since around 8. My store admin was also unavailable as well, but that is now back up.

0 Likes
jg_va
Tourist
5 0 0

We are getting these as well - since 7.55pm GMT

0 Likes
TealAtom
Tourist
3 0 1

Acknowledged now

What happened?
Some merchants are having issues loading different pages in their Shopify Admin. Our APIs are facing a similar issue. We are investigating and will keep you updated.

Status
Investigating

https://www.shopifystatus.com/incidents

Brian_C
New Member
3 0 0

Mine started at 1:00 pm CST

0 Likes
KTD
New Member
1 0 0

We are getting the same issue right now. Is there any way to fix it?

0 Likes
KiLLeRRaT
New Member
7 0 0
TealAtom
Tourist
3 0 1

That's not good. So you've had problems for nearly 2 hours?

0 Likes
Conner
Explorer
46 1 9

Thanks @TealAtom, I'll keep an eye out for an update.

0 Likes
ecedeno
New Member
1 0 0

It seems that now the requests are requiring to set the Host header.  I was getting the error, tried the same Get method in Postman and it worked.  Then noticed that if I disabled the Host header it failed the same way.  I changed my code to include the Host using my shop name, and it is now working.

0 Likes