API versioning

Solved
New Member
26 0 0

Hi Team,

 

From the Shopify API documentation we came across the 3 API versions which are currently supported.

2019-04

2019-07

2019-10

 

The following is also mentioned in the document.

1. "If your app calls a stable version that is no longer supported, then Shopify falls forward and responds to your request with the same behaviour as the oldest supported stable version. For example, in April 2020, API requests that call version 2019-04 will be served version 2019-07, because that will be the oldest supported stable version."

 

And

 

2. "Each stable version is supported for a minimum of 12 months."

 

So I was just curious to know what would happen if I provide the version 2019-01 in the API calls to confirm the point 1 mentioned above. But unfortunately I got an error 404 -Not found. Since the API document says that each stable version will be supported for at least 12 months and also if we provide any unsupported version in the API call, Shopify will fallback to the oldest stable version, I was expecting to receive a proper response and not 404.

 

Can anyone please help me with this.

This is urgent.

0 Likes

Success.

Shopify Staff
Shopify Staff
249 34 38

Hey @agaonkar,

 

API versioning was announced in April 2019. I.e. 2019-01 didn't exist. This is why it isn't falling forward.

0 Likes
Highlighted
New Member
26 0 0

Thank you!

0 Likes