App Bridge - Close cart Pos action only available with Android v5.50.0 or above

Solved
Highlighted
Pathfinder
126 10 19

I am trying to close my embedded app after a certain action and it's not working: https://shopify.dev/tools/app-bridge/actions/pos

 

The link says this action is only available on Android for POS v5.50.0 or above. I uninstalled and reinstalled the app and it still says POS v3.50.0.

 

What is version v5.50.0 and how do I install it? I am using a Pixel 1 running Android 10. 

0 Likes
Highlighted
Pathfinder
126 10 19

This is an accepted solution.

I solved it, the documentation appears to be incorrect (also referenced here:https://community.shopify.com/c/Shopify-APIs-SDKs/Suggestions-for-Shopify-App-Bridge-POS-documentati...)

 

 pos.dispatch(Pos.Action.CLOSE);

as it's written in the documentation, doesn't work.

 

 pos.dispatch(Pos.ActionType.CLOSE);

as it was originally written, apparently, does work.

0 Likes
Highlighted
Shopify Staff
Shopify Staff
17 5 3

Hey @policenauts1 ,

Thanks for bringing this to our attention. We have gone ahead and updated both the proper syntax for POS Close and the correct version of Android that's required to use the action.

I do apologize for causing you any headaches along the way.

 

Enjoy the rest of your day.

Andrew Apperley
(App Bridge) Mobile Developer
0 Likes