Cannot set "track quantity" to false

Solved
luis_vargas
New Member
3 1 1

I am using the Python Shopify API, and I am trying to set the "Track quantity" field to false, but I have tried the following, and it does not work:

 

 
variant = shopify.Variant()
variant.inventory_management = "shopify"
variant.fulfillment_service = "manual"

It is still showing as follows in Shopify:

Screen Shot 2020-05-22 at 12.16.28 PM.png

0 Likes
luis_vargas
New Member
3 1 1

This is an accepted solution.

This will work:

 

variant = shopify.Variant()
variant.inventory_management = None
variant.fulfillment_service = "manual"

 

0 Likes
inuar
Tourist
8 0 1

I have exactly the opposite scenario, I have it disabled on the UI and I am trying to set it to true using PHP API.

'fulfillment_service' => 'manual',
'inventory_management' => 'shopify',  

 I've added on both variant level and product level, but it seems it does not take any effect. any suggestion what I am missing?

0 Likes