Confirmation emails not being sent! PROBLEM may be Shopify not giving Bronto the right access

New Member
2 0 0
In Brief
 
It seems to me that Shopify/Cloudflare are not giving the Bronto connector an access that it needs to refresh permissions and as a result our shipping confirmation emails are not going out. 
 
In Detail
 
Up till now we have used Bronto to send out our shipping confirmation emails. But we are thinking of beginning to use Shopify. Shopify chat told me that simply disabling the send messages instruction in Bronto should push the Shopify system into sending out its own shipping confirmations. (For various reasons we only send shipping confirmations, not order confirmations.) On their side Bronto told me to switch off the sending toggle and then press the Sync button. This would trigger the workflow shown at https://shopify.dev/tutorials/authenticate-with-oauth 
 
I switched off the messages, I pressed the Sync button, and then clicked Yes to Refresh Shopify Permissions. This triggered point 2 in the Help page at https://shopify.dev/tutorials/authenticate-with-oauth
 
"The app redirects to Shopify to load the OAuth grant screen and requests the required scopes.”
 
But it never got to point 3 : "Shopify displays a prompt to receive authorization and prompts the merchant to login if required."
 
The url the app reached out to included a lot of stuff that looked like Family Tickets and Shopify bound together so on the face of it was alright. 
 
But instead of getting to point 3 it got a 403 forbidden, Cloudflare. So I guess it might be something very complicated that is an interaction of Shopify and Cloudflare. 
 
I was unable to approve Bronto's connections with Shopify. 
 
First it went to a Google Chrome message warning of insecurity. I clicked through on Advanced but when I got to the next  page there was a message reading "403 Forbidden cloudflare”.
 
One oddity about the insecurity - on a higher level of Chrome a message said the security certificate was wrong, but when I clicked through to a lower level, the message there said the certificate was alright. 
 
So I never got to the stage of Shopify sending out shipping confirmation emails.
 
But then things got worse. When I switched the yes/no toggle back to yes in Bronto it did not resume sending the shipping confirmations. I presume it has now lost permissions in some way. 
 
I have raised an urgent support ticket with Bronto and while doing this their support agent made this comment "I already saw the new order but still, no message has been sent (only some contact fields were updated)."
 
I think it most likely the problem lies on the Shopify side of the line as, via Cloudflare, the Shopify system is denying Bronto access. I cherish the hope that if we can get the permissions to refresh as they are meant to then everything will start working as it’s meant to. 
 
Any suggestions from anyone?
 
FYI, I am using Chrome on a Mac. 
0 Likes