Deprecated API calls made for no apparent reason

miha93
New Member
1 0 0

Hi I have the following warning on my API Dashboard

"The inventoryQuantityinventoryQuantityAdjustmentrestock and other fields related to legacy inventory calls have been deprecated. The location_id is now required when creating fulfillment and refund requests".

I went over all of our code we are using 2020-01 for all of our API calls and pass location_id for all the endpoints that required it. We didn't get the Shopify deprecated headers in any of our requests. Is there a way for us to see what request has caused this warning to appear? How can I troubleshoot this warning? I tried everything I could think of but the warning won't go away

0 Likes
CalD
Shopify Staff
Shopify Staff
91 8 12

Hey @miha93,

Can you provide a link to the app on your partner dash? We can then take a look further in the logs. 

CalD | Developer Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

0 Likes