Disappear "link" tag in header

Solved
JustUsername
Tourist
3 0 0

Good day!
I want report bug (or probably it must work in this way with new changes).
I have GET-request which looks like this: "/admin/api/2020-01/orders.xml?limit=250;fields=id,note,created_at;created_at_min=2020-12-14T00:00:00+02:00". It's response me 250 orders and I 100 % sure that in request must be more then 250 orders. But response header didn't attach me link to next page.
When I delete "limit" in request, all work fine. In 30 of december I did first tests of request and it worked fine.

0 Likes
Greg_Kujawa
Shopify Partner
1016 83 238

This is an accepted solution.

Not sure if your post had a typo for the 2020-01 API version, since that's now deprecated. But I tried a similar API request. The only differences were I properly separated the query parameters with the & symbol, I cut down the page to only 2 records, and I extended out the created_at_min threshold. Below is a screen shot of the result. The Link response header is definitely there...

 

Untitled.png

JustUsername
Tourist
3 0 0

I tried to change number of records and "link" tag appear. I started this topic because it was 739 records. Looks like in orders status or something else changed and biggest half of them was hidden.
Anyway. Thanks a lot for help!

0 Likes
Greg_Kujawa
Shopify Partner
1016 83 238

This is an accepted solution.

Another quirk is that including status=any as a query parameter will also help unearth records that should be appearing in the response.

JustUsername
Tourist
3 0 0

Yes! With status=any I get the same state that was at 30 of december.
Thank you very much!

0 Likes