Error when installing an app

Robert25
Shopify Partner
4 0 1

Hi, 

I try to install an app for a merchant who can't and see that only new merchants have the same problem. I created a new store and tried the same getting the same error, telling me that it can't be installed because of not supporting some features of the strore.

I get this Request ID: 7b0612f7-ce7c-43a6-9ea2-0c1680262123

Can you help me ?

0 Likes
CalD
Shopify Staff
Shopify Staff
130 17 19

Hey @Robert25,

Check this similar post here: https://community.shopify.com/c/Shopify-APIs-SDKs/quot-The-Shopify-API-application-is-not-compatible...

From the logs, I can confirm it looks like there are certain requirements set out by the app which the store you tried installing on doesn't meet, however the specific requirements that prevent installation aren't logged. Can you double-check any Merchant install requirements you've specified that may be at work?

Also, if necessary, can you send the app id from your partner dash? (i.e. the 7654321 from https://partners.shopify.com/1234567/apps/7654321)

CalD | Developer Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

0 Likes
Robert25
Shopify Partner
4 0 1

Hi CalD, 

Did Shopify change anything in the Merchant Install Requirements over time. Seems that older Shopify accounts can install our app, while newer accounts cant. Is there a change log to the requirements ?

Also what is the process from here? If we find out what requirement we did not support and change it so we do, how do we get "enabled" again? Does it happen automatically?

 

 

0 Likes