Getting Error: "2019-07 is not in the defined version set: unstable, 2019-04"

Highlighted
Shopify Partner
15 0 0

Hi guys,

 

Trying to upgrade my apps to use the new API Versioning, however, when I set the api version to "2019-07" (the latest stable version), I get the following error message:

 

"2019-07 is not in the defined version set: unstable, 2019-04"

 

Any ideas why I am getting this error?  Is there something that needs to change on my test store to specify which version if can use?

 

Thanks!


Matt.

 

0 Likes
Shopify Staff
Shopify Staff
1028 68 135

Hey @Matt28 , 

 

Would I be correct in assuming this error is being returned while using the shopify_api gem? 

 

If so, you should be able to update your version to resolve this - Version 7.0.2 was released with support for API version 2019-07.

0 Likes