How do I upgrade my Shopify API in Laravel --> I Need Help | Covid

Highlighted
New Member
1 0 0

Hi,

I am a Shopify Partner.  I have one of my App developed in Laravel.

Currently its using old API 04-2019 and i am looking to upgrade. My App is using Product | Theme | Billing APIs

Is there any documentation to upgrade in laravel?

I am a developer and currently my Dev is a Covid Patient :)

Your help is highly Appreciated

0 Likes
Highlighted
Shopify Staff
Shopify Staff
586 71 128

Hey @Anthony_David1,

Wishing your dev a safe and speedy recovery 💪

If you're using a library to make calls to the API using PHP, you may need to update the library. Make sure whatever library you're using supports versioning, and it should allow you to specify the API version in your code. If your app is making calls to the API without specifying a version, the call will use the lowest version and this triggers warnings in the API dashboard.

If you're not using a library, you'll need to manually update your code and include the API version in all API endpoint URLs. 

Let me know if there are any other questions we can answer. 

JB | Developer Support @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes