OAuth redirecting problem in Firefox

New Member
2 0 1

There seems to be a problem with opening the embedded Shopify app in Firefox,

It's been a long time since we've used our App properly in Firefox, since a few days ago when users wanted to open our App in Shopify in the Firefox browser,

they are redirected to a strange page like the screenshot.

And I don't know why it added adminNext=true at the end of the app url.

It should be a new change in Firefox new version. But I don't what exactly.

The App can be opened in Chrome-browser without any problem.

 

 

Screenshot 2020-01-22 at 17.07.34.png

1 Like
Highlighted
Shopify Partner
41 0 28

I can confirm the same problem with embedded app in latest FireFox 72 version.

But this seems to be caused by an error in Shopify script . 

You can see the error in the below screenshot from FireFox Developer Console.

 

BUT IT WORKS  IF I REMOVE adminNext from URL:

 if I remove this "?adminNext=true" parameter added to the end of this broken page URL then the embedded app loads perfectly fine!!! We don't add the adminNext param as the OP also mentioned.

So clearly this is something caused by Shopify redirection script as seen in the errors below.

 

 

 

Screen Shot 2020-01-24 at 2.40.44 PM.png

 

 

Error: Error completing request. A network failure may have prevented the request from completing. Error: TypeError: NetworkError when attempting to fetch resource. vendors~main-0c90ef56074c7fbf44e175da9558cc2ca6269bab0b489c3737c5bec1ca518d6c.js:1:51802

This is the link to script causing the error

view-source:https://cdn.shopify.com/shopifycloud/web/assets/latest/vendors~main-0c90ef56074c7fbf44e175da9558cc2c...

 

1 Like
Highlighted
New Member
1 0 0
We are also facing similar issue with our shopify embedded app development using Firefox browser. Our problem is it "Fails by continuing to refresh or redirect". It seems to be a cookie problem in Firefox browser. However in our app we don’t use cookie.

Our temporary fixed is
we tried to set the Firefox manually by entering the about:config then set below to true:

network.cookie.sameSite.laxByDefault

By doing that, refreshing issue is gone.

We are still looking for a right fixed with this issue. We don’t have problem using chrome even using their latest update about cookie samesite to none.
0 Likes