Problem with adding and updating products

Solved
Highlighted
New Member
3 0 0

We have used the Shopify API for a couple of years now without any problem but yesterday June 1:st at 11.16 AM GMT we started to get errors from Shopify saying SSL read: error. It takes very long time like 10-15 seconds and then we gets a response 500 with that SSL read error. Of course we get a dump from our code but I don’t see any special there. It’s a PHP solution that use Laravel and the standard Shopify API.

 

We are sending in the product data as a json string, see sample below

 

Some of the transactions are processed ok but others gave error. What we can see is that if we add to many characters in the description field we get an error.

 

Still there are thousands of products with way longer descriptions that has been added before without any problem.

 

The errors continued the rest of the day or at least until 08:52 PM GMT when the last entry for the day was processed.

Today in the morning everything worked fine but then again at 11:17 AM GMT we started to get errors again and that’s the situation right now at 10 PM GMT.

 

Has anyone had any problem like this?

 

Sample of json

 

{

   "title":"Nya skatteregler för företagssektorn. Prop. 2017/18:245",
   "commcust":null,
   "description":"Propositionen innehåller bland annat förslag som innebär:<ul><li>Att bolagsskattesatsen sänks till 20,6 procent i två steg fram till 2021.<li>En generell begränsning av ränteavdrag i bolagssektornen enligt en så kallad EBITDA-regel med ett avdragsutrymme om 30 procent samt en alternativ förenklingsregel där beloppsgränsen sätts till fem miljoner kronor.<li>Att det införs ett så kallat primäravdrag för hyreshus i syfte att upprätthålla den höga takten på byggandet av hyreshus.<lii>Ett avdragsförbud för ränta vid vissa gränsöverskridande situationer (hybridregler).<li>Att reglerna om begränsning av ränteavdrag för vissa interna lån som motverkar aggressiv skatteplanering snävas in och blir mer träffsäkra.<li>Att skatteregler om finansiella leasingavtal införs.</ul><br>",
   "id":"8F1C884AE0BAC95CC125829F004A7314",
   "type":"print",
   "primary":"true",
   "oldfidoid":"8F1C884AE0BAC95CC125829F004A7314",
   "verkid":"P0000094551",
   "image":"https://image.nj.se/product/pubtype_prop.png",
   "publisher":"Finansdepartementet",
   "subjectarea":"Ekonomi & Näringsliv,Straffrätt & Rättsväsen",
   "subtitle":null,
   "target group":null,
   "searchwords":"ränteavdrag, bolagsskattesats, EBITDA, primäravdrag, aggressiv skatteplanering, ",
   "datechanged":"2020-04-16",
   "meta":{

      "serie":"Prop. 2017/18:245",
      "prodtype":"OP MIG",
      "imprintcode":"OP",
      "printPer":null,
      "courselitterature":"false",
      "directive":null,
      "edition":"1",
      "isbn":"PROP1718245",
      "price":"405",
      "priceresellers":"0",
      "size":"555",
      "standingorder":"false",
      "status":"Normal",
      "weight":"1023",
      "plannedPublicationDate":null,
      "published":"2018",
      "published_date":"18-06-01"

   

}

}

 

 

 

 

 

 

0 Likes
Highlighted
Shopify Staff
Shopify Staff
582 70 127

This is an accepted solution.

Hey @ThomasLindqvist,

 

Can you provide the X-Request-ID from the response headers of your call? I'll check our logs to see if there are any errors there.

 

As well, can you confirm that the system time is set correctly on your server? Intermittent SSL errors can sometimes be caused by an incorrect time set on the server.

JB | Developer Support @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes
Highlighted
New Member
3 0 0

It started to work again June 3 and has worked since then without any problem. We haven't change anything on our side. Will check the time on the server. Thanks for you help 

0 Likes