REST ADMIN API facing issue create customer

Highlighted
Tourist
3 0 1

API call https://{{api_key}}:{{api_password}}@{{store_name}}.myshopify.com/admin/api/{{api_version}}/customers.json

- I have set key -password - name - version in postman environment.

Post Dats in raw json

 

{
"customer": {
"first_name": "Steve",
"last_name": "Lastnameson",
"email": "my@email.com",
"phone": "+15142546017",
"verified_email": true,
"addresses": [
{
"address1": "123 Oak St",
"city": "Ottawa",
"province": "ON",
"phone": "555-1212",
"zip": "123 ABC",
"last_name": "Lastnameson",
"first_name": "Mother",
"country": "CA"
}
],
"password": "newpass",
"password_confirmation": "newpass",
"send_email_invite": true
}
}

Response said this

 

 
 
    window.location = "https:\/\/app.shopify.com\/services\/login\/identity?destination_uuid=ef65c0fd-0cf4-4a0c-ad5a-1e30114ff8df\u0026merge_ignore_postponed=false\u0026prompt=merge\u0026return_to=https%3A%2F%2Fapp.shopify.com%2Fservices%2Flogin%2Fidentity_callback%3Ffrom_signup%3Dfalse%26locale%3Den%26shop_name%3Dcolorchain%26state%3DOcgguS6sW8XPt7TrffAfmyw6SyHLuABgbqAKTGas6I9rEu5oTUvrqiyOOKAIvoDj3JJJHgkaHT__K4xTk8JA00ZnWHDWkc9oMakXnvqZ-Bjt9TPwxoaYzHGyB2wzO27NASUbIMWgs6Z41y7mbw3rDiNC-z6bEfCET0aAa0YR5lzkPH1gYeC2aeV6Bm0CCv2_4Zx6EOXM4pge2C7PI3eTa1HxDDTvSLL7qHm15qcxfLM%253D\u0026ui_locales=en\u0026ux=shop";
  
1 Like
Highlighted
New Member
2 0 0

I also face the same problem now.

Did you have already solved it?

0 Likes
Highlighted
Tourist
3 0 1

Yes, I Resolve this issue.

 

1st - If you are using postman then clear cache of the postman and test.

 

2nd - If you directly integrating in the code then Pass Key and password in base64 format string in header.

https://www.base64encode.net/

0 Likes
Highlighted
New Member
2 0 0

Thank you for quickly replying.

As you say, I was integrating directly with Postman.
I tried both procedures but the result was not changed.
But I avoided the issue in the other way.
(I stopped using Postman, and post from python.)
Thank you for your kindness.

 

0 Likes
Highlighted
New Member
1 0 0

I had the same problem and fixed it by clearing the Postman's cookiesScreen Shot 2020-09-25 at 4.46.35 PM.png

0 Likes