Rails App on Heroku not loading

justinonthenet
New Member
2 0 0

Hi all,

I've been developing my first Shopify app and learning everything as I go. I'm using Rails with Postgres and up until now have been using ngrok. Now I'm trying to move everything over to Heroku and  in the realm of things I don't understand.

I started by following instructions in this guide (up to and including migrating my database):
https://devcenter.heroku.com/articles/getting-started-with-rails6#deploy-your-application-to-heroku

I changed my App URL and redirection URL.

At this point, I could visit my app at https://peaceful-coast-28518.herokuapp.com/
But if I enter my dev store url, I just get a blank screen. And if I try loading the app in the admin, same result. Nothing loads.

After doing some searching, I found this post: https://github.com/Shopify/shopify-app-cli/issues/277#issuecomment-522375162
I added my Config Vars to Heroku (SHOPIFY_API_KEY, SHOPIFY_API_SECRET_KEY, and SCOPES). No dice.

I also found this post where it mentions setting config.embedded_app to false.
I did this and pushed to Heroku.
Once I did this, I was able to go back to my app url, submit my dev store url and see the screen requesting authority to install the app.
I did this and got an error, "The page you were looking for doesn't exist".
When I loaded up the store the app was listed.
However, when clicking into the app I see the same error.

I'm really not sure where to go from here.

0 Likes