Shopify Admin link wrong parameters

priyankaD
New Member
2 0 0

Hi there,

 

I'm Priyanka and I'm Ruby on Rails developer at HulkApps.

 

We have built a Metafields application (Formally known as "Metafields Custom Fields Master") and have implemented Admin-links functionality http://prntscr.com/raq201 in the application.

 

While testing the functionality we found that sometimes the parameter passed in the redirection link is not accurate while sometimes no parameter is passed. I've recorded a video where you can find that when a merchant is accessing the Metafield Admin link from the Customer details page to edit the metafields, the user is redirected to another customer's 'edit metafield' page of our app.

 

The redirection functionality is executed on the basis of the object_id passed as a parameter in the response of the admin link.

 

Video link: https://www.loom.com/share/5a42831959394267809280c22d8b07f7

 

Can anyone please help us with this issue and help us identify why the wrong parameters are passed in the admin link response.

 

Thank you,

0 Likes
SBD_
Shopify Staff
Shopify Staff
1090 147 199

Hey Priyanka,

 

Thanks for reporting this. I'm able to replicate. The bug seems to appear with the use of the back button, a hard refresh resolves the issue.

 

Raising this internally. Keep you posted.

0 Likes
priyankaD
New Member
2 0 0
Hey there,

Thank you so much for your insides. Please let me know once it is solved.

Thanks,
Priyanka Dabawala
0 Likes
SBD_
Shopify Staff
Shopify Staff
1090 147 199

This one appears to be resolved - let me know if you're still experiencing issues.

0 Likes