Shopify CLI [ wait ] compiling ...

Highlighted
New Member
4 0 0

Hi All

 

I'm new to this and wanted to learn how to create shopify apps

 

I've create the app and it is available in my development store.

 

the next stage is to run 'Shopify Serve', which generates the below...

 

It never passes  '[ wait ] compiling ...'

 

I would really appreciate any help? in step by step format please... Thank you

 

┃ ome/comet1/.shopify-app-cli/bin/support/load_shopify.rb:12: warning: Insecure world writable dir /home/comet1/.nvm/versions/node/v12.16.2 in PATH, mode 040777
┃ > shopify-node-app@1.0.0 dev /home/comet1/dreamer_custom
┃ > NODE_ENV=development nodemon ./server/index.js --watch ./server/index.js
┃ Do you want to update your application url? (Choose with ↑ ↓ ⏎)
┃ [nodemon] 2.0.2
┃ [nodemon] to restart at any time, enter `rs`
┃ [nodemon] watching dir(s): server/index.js
┃ [nodemon] watching extensions: js,mjs,json
┃ [nodemon] starting `node ./server/index.js`
┃ Browserslist: caniuse-lite is outdated. Please run next command `npm update`
┃ > Ready on http://localhost:8081
┃ [ wait ] compiling ...

0 Likes
Highlighted
New Member
1 0 0

me too ...

0 Likes
Highlighted
Tourist
6 1 2

I'm having the same issue.

 

Edit:

I was able to get past this by updating my ngrok URL under App Setup and then installing my app on my development store. After that it complied and worked as expected.

0 Likes
Highlighted
New Member
4 0 0

Hi

 

Thanks for the response... Sorry to ask for specifcs, which App Settings? I haven't been able to locate somewhere for the nrog entry.

 

Would you mind adding a screen shot?

 

Thanks in advance

0 Likes
Highlighted
Tourist
6 1 2

After running

shopify serve

you should see an ngrok.io URL in your output. Place that under App setup in your shopify partner account. You might have to re-run shopify serve, then the app will complie. See below screenshot. Hope this helps!

 

 

Capture.PNG

 

 

2 Likes
Highlighted
New Member
4 0 0

Thanks for sending this over. I really appreciate the help, this looks like the solution!

0 Likes
Highlighted
New Member
4 0 0

I have checked the nrok and the url is correct

 

I am still stuck at comiling,

 

I do recevie the errom message Browserslist: caniuse-lite is outdated. Please run next command `npm update`

 

I've tried running the npm update, and several other suggestions.

 

Don't worry if not, but do you have any other ideas?

 

0 Likes
Highlighted
Tourist
6 1 2
0 Likes