ShopifyAPI::ApiVersion::NullVersion is not in the defined version set

Solved
Highlighted
New Member
2 0 0

We have developed the public app with the Shopify in Ruby On Rails after app installed we also creating webhook for Shopify events, while webhook creation getting ShopifyAPI::ApiVersion::UnknownVersion (ShopifyAPI::ApiVersion::NullVersion is not in the defined version set: unstable, 2019-04, 2019-07, 2019-10)  Error.

 

Please help me to resolve this issue.

Thank You!

 

Screenshot from 2020-02-12 17-50-09.pngScreenshot from 2020-02-12 18-05-38.png

0 Likes
Highlighted
Shopify Staff (Retired)
Shopify Staff (Retired)
624 102 129

This is an accepted solution.

Hey @99Minds ,

 

Looks like the error you are facing was a bug that was identified in the open source repository for the shopify_app gem: https://github.com/Shopify/shopify_app/issues/788

 

The solution here would be to update your app_gem to version 11.0.2

 

Hassain | Developer Support Specialist @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes
Highlighted
New Member
2 0 0

Thank you so much for your reply, It's version issue while calling API, I do not specify API version

0 Likes