Stuck in "Enable Cookies" loop in Safari

New Member
2 0 3

Working on a Shopify App. I have followed pretty much every step in the blog post of building a Shopify app with node and react, and I have reached a little bump on the road.. When installing the app on Chrome, it works fine, but if I then open Safari and log in to my test development store and try open the app, I get a request to Enable Cookies. This is fine, as we of course want to comply with the ITP rules and all, but every time I click the button and gets back to the app page in Shopify, I get redirected back to the Enable Cookies screen again. I have checked the console, and the cookies has been created on my ngrok domain, but no matter how many times I click the button I keep getting redirected back to enable cookies.

 

Worth noting is, that this doesn't occur in incognito mode. If I open Safari as incognito, and click the enable cookies button, I am redirected back to use the app in Shopify.. 

 

Any clue what is going on?

 

PS.. I have tried to empty cache, removed cookies from both sites in Safari and also updated to the latest version of koa-shopify-auth from Github.

3 Likes
Highlighted
New Member
1 0 0

Same issue - there's really no responses to this problem? Were you contacted about this, OP?

 

Cheers

 

BA

0 Likes
New Member
2 0 3

Haven't heard anything yet no.. I have tried to work my way around it, and so far it seems to be working.. But honestly I can't recall exactly which steps I took in order to get passed it. I thought - since nobody else had replied or reacted with similar issue, that I was a unique case, and my browser just was the problem.. One thing I do recall doing was changing the <AppProvider /> shopOrigin attribute to be explicitly specified: 

shopOrigin={shopOrigin}, as escaping it as a variable didn't seem to work properly. I will have a look at my git repo to see if I can locate the commit that changed the behaviour.
 
Cheers
 
PJB
0 Likes
New Member
1 0 0

Was anyone able to figure out the cause of this? I'm having the same problem...

0 Likes