The application drops out of the iframe with a fresh install

antdev
New Member
1 0 0

Expected behavior:

Install App:

- go to partners.shopify.com->Apps->Click on AppName->Test your app->Select Store->Install App
- After click on Install App will a window appears with a list of different scopes and different install information
- After this -> press Install App btn
- After this Subscription page will be appear -> press on the Approve subscription button
- After this App should be installed and index page of my App should be appear in iframe.

Current Behavior:

Install App:

- go to partners.shopify.com->Apps->Click on AppName->Test your app->Select Store->Install App
- After click on Install App will a window appears with a list of different scopes and different install information
- After this -> press Install App btn
- After this Subscription page will be appear -> press on the Approve subscription button -> this redirect me to the index page of my App in the same tab without shopify menu(not in iframe).
But actually App is installed and working well when I open my app from my store-> Apps->My-App.

We are redirected to home page after billing process, so Shopify should open it in Iframe.

I tried do force redirect it to the url of my App( https://' .$shopName . '/admin/apps/' . strtolower(env('SHOPIFY_APP_NAME')) , but shopify app name can sometimes consist of application name and Id(my-app-7), something like:
https://my-shop1.myshopify.com/admin/apps/my-app-7
so, I can't know exactly the url of my application

We are not use AppBridge on the our frontend part.

So, how can I fix this issue?

Thanks in advance!

 

0 Likes