Trouble getting POST request to admin/api/2021-04/orders/123456789/fulfillments.json to work

ben_eversfield
New Member
3 0 0

Hi there,

 

I've got a private app connected to our store. It works (mostly) fine. GET/POST/PUT are all working.

I'm now trying to create a fulfillment on an order.

Calling GET to the endpoint admin/api/2021-04/orders/123456789/fulfillments.json works fine. It returns an empty array - because there's no fulfillment yet. I've also tried other, less recent versions of the API.

Changing that request to POST, and including a body like

 

{
  "order": {
    "note": "Here is a note by Ben on this order!",
    "financial_status": "paid"
  }
}

 

 

Returns another 200 success, but gives me a link like https://accounts.shopify.com/oauth/authorize?client_id=.........

That then logs me in, and returns the dreaded 'We'll be back soon' (They never are).

I've given the app read and write privileges for everything conceivably related. I'm also able to POST requests on all my other endpoints so far.

I'm using Postman, cleared all caches. Also using Python requests, same thing. Same link, same error screen with the infuriating sign. I've tried multiple browsers, Incognito, a fresh browser installs, multiple devices.

If anyone knows how to sort this problem, I'd very much like to hear their thoughts.

Screenshot 2021-04-01 at 07.23.17.png

 

 

 

0 Likes