URGENT: '@shopify/polaris@^3.16.0' is not in the npm registry

Solved
Highlighted
Shopify Partner
88 14 27

Can an admin have a look at this?

npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.yarnpkg.com/@shopify%2fpolaris - Not found
npm ERR! 404
npm ERR! 404 '@shopify/polaris@^3.16.0' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)

0 Likes
Highlighted
Shopify Partner
593 41 118

Something must be wrong with your local setup. If you click the URL that referenced as not found you'll see it leads to the registered package. When I just queried from a host it worked fine as well.

 

vm-admin@RubyOnRails-VM:~$ yarn info @shopify/polaris
yarn info v1.21.1
{ name:
   '@shopify/polaris',
  description:
   'Shopifys product component library',
  'dist-tags':
   { latest:
      '5.1.0',
     next:
      '5.0.0-alpha.3' },.......
0 Likes
Highlighted
Shopify Partner
88 14 27

This is an accepted solution.

Hi,

Problem was not with local setup but on server build, obviously something to do with the package itself. I just re-executed the build on the server and it is fine now.

0 Likes