Webhooks created through private app don't fire on callback URL with custom port number

Tourist
6 0 0

I have successfully done webhooks integration through web admin webhooks (Settings > Notifications)

And I am now trying to run webhooks through private app. Created all webhooks through private app and removed webhooks on web admin.

It works through ngrok successfully on my local machine, but it doesn't seem working on our development machine and cannot find requests on IIS logs. Difference is just port number. Our development machine use custom port 446 for https so the url like https://domain-name:446/webhook...

Does anyone know whether it is related with port number? 

 

Thanks

Ray

 

0 Likes
Tourist
6 0 0

Thanks for your response Josh. Appreciate testing for my case.

 

That port number 446 works on webhooks created through admin > settings > notification > webhooks. We are currently using this way and moving to private app webhooks. Port number 446 only does not work on webhooks created through private app.

so are you saying custom port number only works on webhooks created through admin > settings > notification > webhooks?

0 Likes
Shopify Staff
Shopify Staff
1105 77 144

Hey @Ray14 , 

 

Apologies for the confusion, my post prior to this was actually incorrect. Would you mind letting me know which shop this webhook is set up on? I'm assuming it will likely be the only URL with a port number on it, so just the shop URL should be enough to look into this. I'll be able to check our logs and there may be an error message present to point out where things are going wrong.

0 Likes
Tourist
6 0 0

Hi Josh,

 

The shop URL is https://kudosdevelopment1.myshopify.com.

 

0 Likes
Tourist
6 0 0

Hi Josh,

 

I have received a notification from Shopify that my webhook is failing. I have set Let's Encrypt to port 446. Do you know why this error occurred?

As I mentioned, the webhook works if I create it through admin>settings>notifications>webhooks.

Recent failures:

September 7, 2019 at 5:40 pm

Error: local error: tls: no renegotiation

Store: kudosdevelopment1.myshopify.com

 

Thanks

 

Ray

0 Likes
Shopify Staff
Shopify Staff
1105 77 144

Hey again @Ray14 , 

 

Sorry for the late response here - I looked at log entires on our end for your webhook URLs though and unfortunately there isn't any information available outside of the error message that you were shown already (presumably via our automated webhook failure e-mails). 

 

Would you be able to temporarily open up traffic to all ports just to see if the webhooks aren't being sent where you expect? 

 

I can see that we're sending them to dev.kudos.co.nz:446 and including the port number, so it's hard to say where things could be going wrong otherwise with the limited information I have. There aren't any timeouts occurring though, I'm just not seeing a 200OK response.

0 Likes
Highlighted
Tourist
6 0 0

Hi Josh,

 

I am unable to open up all ports for wehbooks as other apps are running in same machine.

There is a certificate on dev.kudos.co.nz and pointing to 'A' machine and another certificate on dev.kudos.co.nz:446 and pointing to 'B' machine.

Do you think this environment could cause a 'local error: tls: no renegotiation' error?

 

 

0 Likes
Shopify Staff
Shopify Staff
1105 77 144

Hey @Ray14 , 

 

Really sorry this took so long - this one slipped through the cracks somehow. 

 

That definitely seems like a non-standard setup, I don't know that Shopify would normally support that. The other endpoint without a port number you have set up is working fine though I assume?

 

Otherwise, I wonder if changing the port may work since the default SSL port is normally 443. Would it be feasible to set up another domain for this if that doesn't suffice?

0 Likes
Tourist
6 0 0

Hi Josh,

 

Thanks for your response.

Then why webhooks created through Settings -> Notifications -> Webhooks are working even if 446 port is used.

It doesn't make sense. The webhooks, only created against private app don't work. I am unable to use 443 port because it is taken by another machine in our network.

 

Ray

 

 

 

 

 

 

 

 

 

0 Likes