Why is my VS Code editor auto saving when I type? (ngrok to many connections)

Solved
Highlighted
Excursionist
14 1 3

I have an annoying problem that when I type in my VS code editor, my app is auto refreshing many times over and it's causing my NGROK tunnel connection to fail while working on my app.

 

Is there a way to stop this?

 

It's actually a cool feature but w/ the limited ngrok connection it's really becoming a problem.

 

I'm using the Shopify App CLI for a node/react app.

 

Screenshot_2019-12-20 oneezy ~ Add Script Tags ~ Shopify.png

0 Likes
Highlighted
Excursionist
14 1 3

This is an accepted solution.

Fixed!

 

For anyone else having this problem, it has to do with TypeScript's auto detect feature that's built-in to VS Code.

 

You'll need to go to your settings and do a search for "auto save"

 

Find:"TypeScript > Tsc: Auto Detect"

 

Turn it off.

 

image.png

0 Likes