how to prevent emails from sending to customers when importing historical orders

New Member
21 0 0

Ken - Here is the reply I received.  I have no idea why Shopify has failed to update the documentation with this critical piece of info!  Seems as though the product managers could care less.  You need to add the "suppress_notifications" property in the request and set it true.

 

Adam Archibald (Shopify)

Aug 11, 14:15 EDT

Hi Bill,

Adam form Tier 3 Support Development here,

The behaviour you are is seeing is due to the app being selected as a sales channel. The notification settings on sales channels supersede those passed in your api call, which is causing it to send the notification email. If you deselect the app options that allow access to "Custom Storefront" and "Custom Checkout" the notifications should begin behaving correctly.

 

If you require these options for the app to function correctly, using "suppress_notifications": true, will turn off notifications for the order.

Hope that helps!

Adam Archibald
Shopify - Ottawa HQ
Tier 3 - Support Development

0 Likes
New Member
2 0 0

Hey Bill,

"suppress_notifications"option works correctly.

Thank you for quick help.

Warm Regards.

0 Likes
New Member
1 0 0

I too was NOT able to get any of the emails to prevent from sending to customers... until I added "'suppress_notifications' => true" attribute. This is absolutely nowhere to be found in the Orders API Help Center and should be fixed ASAP by the engineers. This is not mentioned anywhere.

0 Likes
Highlighted
Tourist
10 0 0

I am creating an order with draftOrderCreate and draftOrderComplete using GraphQL Admin API.

But when creating the order, the email is sending to customers now.

Is there any way to prevent this?

0 Likes