need developer help with Shopify API Private apps within days

RDR
Tourist
10 0 2

Shopify says: you can update the API version yourself, we still recommend the forums and/or a developer to look them over before updating. This video should help you understand how to edit the API versions

API versions for most of our private apps are about to go unsupported and we want to know if any issues will occur if I update the API version yourself or if your developer needs to do any extra work before updating the API version?  The old developer is no longer with the theme creator company, and they only wrote this:

We have the link to the most recent version of the codebase that we have, which includes the code for all apps. You can download from that link. The files in github may not be up to date, so I'd recommend downloading them directly from the RDR DigitalOcean server (owned by us). we can can share credentials. Once connected, files are at /var/www/html. Depending on what needs to be done, the github repo may or may not need to be updated with their live theme as well.

The only file in the apps that has any reference to the deprecated allocationMethod field one value is app/types/graphql.ts, which is gitignored with the comment "Built graphql type definitions". More on that: the "Create Shopify App" was one of those projects Shopify released, marketed to devs and then abandoned a year later, from our findings. That setup would have generated the readme, so we didn't write those instructions. That setup would have also generated the .gitignore, and we definitely did not set up a graphql typescript file, so it must have just been something Shopify included automatically.

 

All that context to say, this API update may not even impact this app at all, there's no way to tell without updating it.

 

Thank you,

Ashley

 

Please let me know how we can get this addressed before it's too late

 

Help is MUCH appreciated.

0 Likes