"The Shopify API application is not compatible with the features of the shop" error

Zolbayar
Shopify Partner
43 1 3

Hi all, 

I've encountered an error that I have never seen before. It happens when a store owner tries to install our custom app.

Couldn't find any reference to this error message. What could trigger this?

Zolbayar_0-1609947018009.png

 

Working remotely from Mongolia ~ www.gereesee.com
0 Likes
_JB
Shopify Staff
Shopify Staff
834 98 188

Hey @Zolbayar,

Custom apps can only be installed on a single store, can you confirm the app hasn't already been installed elsewhere?

Also if you setup any install requirements for the app (ie. requires merchant located in a certain country, or using a certain gateway), make sure the shop you're attempting to use fulfills those requirements.

If that doesn't explain it, please provide the X-Request-ID from the response headers of the error page in your screenshot, and we can investigate further. 

JB | Developer Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

0 Likes
Zolbayar
Shopify Partner
43 1 3

Hey @_JB ,

Thanks for replying (but 16 days after!), 

It happened again in our development store. But the installation went successful when I tried again after a few hours. The same thing happened to our client too.

Couldn't reproduce the issue. 

Working remotely from Mongolia ~ www.gereesee.com
0 Likes
zari_azeem98
New Member
3 0 0

Are you able to have the custom application on the live store and the development store at a time because they say that these are only meant to be installed on a single store. But the development store doesn't count, right?

0 Likes