"shopify node serve" Command Problem

Solved
bdowling
Explorer
66 13 39

Hi, I'm trying out the Shopify CLI. I'm going through this tutorial. I'm using Windows 10. 

Running "shopify node create" scaffolds the new project but when I run "shopify node serve" I get this error:

√ curl @ C:/WINDOWS/System32/curl.EXE
√ tar @ C:/Rtools/bin/tar.EXE
- Installing ngrok...
X System call failed: tar -xf C:/[...]/shopify/ngrok.zip

(I inserted the "[..]" to hide personal info in the folder name)

The ".../shopify/ngrok.zip" DOES exist. I tried deleting it and running "shopify node serve" again but same thing happens.

Based on this. I think "shopify node serve" is downloading a zip -- thinking I'm on MAC -- and then since I'm on Windows, it tries to tar(untar?) the zip file.

Am I missing something or should I report a bug? 

L_J_K
Shopify Staff
Shopify Staff
145 15 24

Hey @bdowling 

Thanks very much for raising this! Yes - sounds like it could be one for the CLI team to run their ruse over.

By all means, feel free to log an issue in the following repository. Much obliged!

| API Support @ Shopify |
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
bdowling
Explorer
66 13 39

This is an accepted solution.

Hi, thanks for the reply. In case someone has a similar problem, I manually unzipped the file and was able to use the command with no problems after than.