webhook request script for Java and/or Ruby 2.2.10

ForTheWin
New Member
1 0 0

Hi, I have been trying to verify a shopify webhook and referring to this page: https://shopify.dev/tutorials/manage-webhooks.  Our app uses Ruby version 2.2.10, so I installed the shopify_api  gem version 6.0.0.  I realize that this version is deprecated and requests could possibly break.  However, I was wondering if there is a different webhook request script I could use for Ruby 2.2.10?  

Also, is there a webhook request script in Java?  There are plans to use a new Java Framework (Spring) to separate out from Rails.  On https://shopify.dev/tutorials/manage-webhooks, there's scripts for Ruby, Python, and PHP, and I'm wondering if there's one for Java as well.

0 Likes