App Proxy SSL auto-redirect

Highlighted
Shopify Partner
8 0 0

I'm working on a store that uses a custom primary domain (e.g. store.CLIENT.com) and an app proxy url to access our unlisted app (e.g. store.CLIENT.com/tools/APP). SSL is working elsewhere in the store and auto-redirecting.

 

I've noticed that certain browsers (Edge, Chrome) don't automatically redirect the app proxy urls tho. This is causing some unexpected behavior.

 

Any idea why that would happen or how to force that url to SSL as well?

0 Likes
Highlighted
Shopify Partner
8 0 0

Summary: Shopify does not automatically redirect to SSL when accessing app proxy urls

 

Replication:

  1. Create a custom Shopify app (e.g. STORE.myshopify.com/admin/app_installations/app/APPNAME)
  2. Configure an app proxy url in the app (e.g. STORE.myshopify.com/tools/PROXYPATH)
  3. Launch the Microsoft Edge or Google Chrome web browser
  4. Navigate to the proxy app url without SSL (e.g. http://STORE.myshopify.com/tools/PROXYPATH)

Expected behavior: Shopify will redirect the browser to an SSL-enabled URL (e.g. https://STORE.myshopify.com/tools/PROXYPATH)

 

Actual behavior: The browser is not redirected, and the proxy URL loads without SSL enabled.

0 Likes
Highlighted
Shopify Partner
55 1 11

Any response from Shopify would be appreciated.  We are seeing this issue as well.

0 Likes
Highlighted
New Member
3 0 0

Has this been fixed? I tried checking it and the URLs proxy as expected. I tested on Chromium and Firefox on Ubuntu.

0 Likes