App Tutorial Issue: Build your user interface with Polaris

Jogi95
New Member
2 0 0

Hello,

I am new to Shopify App Development and new to Node.js + React. However, I have previous experience with programming (Python) and Web Dev.

Currently, I am following the "Build a Shopify App with Node and React Tutorial". Everything worked fine so far, but in Chapter 4 "Build your user interface with polaris" I am experiencing an 

error message. I followed the steps as described (https://shopify.dev/tutorials/build-a-shopify-app-with-node-and-react/build-your-user-interface-with...) but after importing Polaris Styles and running "npm run dev" for testing,I receive the following error which results in an internal server error:

Jogi95_0-1613302324656.png

Do you have any ideas what causes this issue and how it could be mitigated?

My code is exactly the same as in the tutorial.

Help is very appreciated!

Cheers,

Johannes

0 Likes
Jogi95
New Member
2 0 0

The problem seems to be related to the built-in CSS support which is being deactivated by next.config.js.

Without require('@zeit/next-css') I do not get an error message. However, in another YouTube Tutorial of Shopify which also uses @zeit/next-css no such error occures and everything works.

I will go with the workaround of not using @zeit/next-css for now.

0 Likes