App proxy don't work with 500 internal server error.

New Member
2 0 0

Hi

I have created a app with app proxy for store front.

The proxy work well in localhost (using local tunnel) for testing. 

I have uploaded it to my hosting, but it does not work with 500 internal server error. 

 

the destination url work on browser. but can't call in shopify store. 

Please solve it soon. very urgent. 

 

Thanks

Billy

0 Likes
Tourist
8 1 0

Did you manage to find a solution for this? I'm facing the same issue. It worked initially and then stopped. We planned a release by the end of May and this is the only thing stalling everything right now.

 

0 Likes

Have you checked your server logs to see if something on your end is generating the 500 error? You can also use chrome dev tools, select "Preserve log" in the network tab, and then see where the error is triggered. There are a lot of possible reasons why a 500 error would occur, and it'll take some logs and debugging to find the root cause.

0 Likes
Highlighted
Tourist
8 1 0

The proxy never hits my server. The entry point works fine without the proxy. The proxy used to work and then stopped. At some point it was redirecting to "/password" but now I'm back to 500. I saw many unanswered threads more or less with the same issue. Not sure what to think of this. 

 

My entry point is served with SSL, certificate is recognised by the browser if accessed directly, response is what I expect etc. But proxy fails and tells me that "there was a problem with third-part application" but it never hits my application.

0 Likes

Interesting. Could be a problem or change to Shopify. Still might be helpful to look at network logs in your browser to see what's failing (although sounds like the proxy).

 

I've encountered that issue once, but it was because I'm using the free ngrok, and I had to update the proxy URL for my in-development app to an updated ngrok subdomain.

0 Likes