Facebook sales chanel not connecting to my shopify

New Member
10 0 0

I have been having the same problem for over a month now. I used to have a working facebook and instagram sales channel. I had disconnected my facebook sales channel and tried to reconnect it, however Shopify now won't recognise that I am the owner and admin of my page. To get a better understanding, I own 3 facebook pages under my facebook account. When I am initially prompted to log into my personal facebook account, it is not greyed out. It is there. I have tried clicking on it and also clicking on all 3 of my pages to see if it registers along with them. When I select only that page it says that I am not the owner or admin of the page. If I select all 3 of my pages then only 2 appear in the drop down menu and not the one I need.

 

I own this page

It is published

I had changed my @username for my facebook and instagram could this be the problem? If so, why? 

 

I have deleted my sales channel and re-added over and over. When I delete my sales channels the facebook and instagram icons still appear and lead to broken links.

 

Any help would be great

0 Likes
Shopify Staff
Shopify Staff
163 16 25

Hey, @BIASI!

 

Lulu here from the Shopify Support team. Thanks for reaching out here, and I'll be more than happy to help you out.

 

Sorry to hear you are having trouble with the Facebook sales channel. Let's go through some troubleshooting steps and see if we can get to the bottom of this for you.  

In order to connect a page to the Facebook sales channel, you need to be:

  • an Admin on the page in question
  • page is published
  • shopping template is on-page.

Note: If the Facebook page was created less than 7 days ago, or Admin Access was granted less than 7 days ago, please reattempt the connection after allowing this timeframe. Facebook API has a delay of 2-7 days in allowing third parties to recognize the Admin status.

 

Firstly, please make sure the shopping tab is enabled for the store you are looking to connect.

  • Go to the Facebook page you are an administrator for
  • Click 'Settings'
  • Click 'Templates and Tabs' - If this section says anything but 'Shopping', click 'Edit'
  • Click 'View Details' on Shopping and 'Apply Template'
2019-07-3v8tj-yeb75

 

Next, ensure that the page is published and you have Admin privileges. This can be seen in the Settings > General of your Facebook Business page. Can you send on a screenshot confirming these for me?

2019-08-kujgr-ri332

If you are seeing "reconnect account" in the Facebook sales channel, please go to Settings > Sales channels and delete Facebook. When you add it back on, you should then see "connect account" where there's no cache of your previous session.

2019-08-wld6n-rreo3

If you have the correct permissions, see "connect account", and the Facebook Business page is still not appearing for you, then you can disconnect and reconnect Shopify permissions on your Facebook account.

 

Remove the integration that is giving the error, in this case: Shopify.

 

2019-08-enucn-yhw0v

  • After removing the integration, please log out of Facebook entirely.
  • Log back into Facebook on a private browsing window (like incognito in Chrome. Or a browser you don't use often to rule out a cache issue).
  • Go back to Shopify and attempt to connect the Facebook page in the Facebook Sales channel.

The account should then be linked up and the connection should start!

 
I hope this helps. Let me know how you go with these steps or if you see anything strange along the way send me some screenshots and I'll investigate further for you!
 
Speak soon,
Lulu

Lulu | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes
New Member
10 0 0

Hey Lulu,

 

Thanks so much for your response.

 

Everything you've mentioned I have tried in the past over and over, everything.

 

I followed your steps and still nothing.

 

Same error I always get..

 

Just to recap I own this page and it is published

BIASI1.jpg

 

 

0 Likes
Shopify Staff
Shopify Staff
163 16 25

Hi, @BIASI.

 

Thank you for coming back to me and providing that screenshot! Something we are seeing lately is instead of merchants having "admin" under page roles, they have "custom" or "jobs manager". Can you go to Facebook Page > Settings > Pages Roles > and review the roles here and take a screenshot for me. Ensure your Page Roles are set to "Admin” rather than "Jobs Manager" or "Custom". In order to be connected successfully, the permissions will have to be set to "Admin" no matter what.

 

Once you confirm you have admin access and not "custom" or "jobs" manager then I will escalate this up to our Technical team who are monitoring the situation and trying to get Facebook to push through a fix on their side. We, unfortunately, have no timeline with this but I assure you, all hands are on deck!

 

Speak soon,

Lulu

Lulu | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes
New Member
10 0 0

Okay if what you're saying is true then I may see the problem. This is something I spent along time playing around with before to no avail.

 

I have my personal account added with Job Manager role which is no good. However, it says if i delete myself there will be no more admins left. So I'm afraid I won't be able to add myself back and the page will be unmanageable. It's impossible to contact facebook so i didn't want to have thatBIASI2.png happen.

0 Likes
Shopify Staff
Shopify Staff
163 16 25

Hi, @BIASI.

 

Thanks for coming back to me. 

You can actually change this by following these steps:
 
1. Going to your Facebook Business Manager account: https://business.facebook.com/
2. Go to Business settings
23-16-6812m-wkge5
3. Selecting the page:
23-18-fxy1f-ut7ec
 
4. Toggling these options to off:
23-13-hf7w8-nat9w
 
Let me know how that goes for you.
 
Kind regards,
Lulu

Lulu | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes
New Member
10 0 0

You're the best, that was it. Once I turned off these options for my business manager it passed on admin control to my personal account.

 

Thank you so much I've been trying to figure this out for so long I overlooked the simple things.

 

Thanks LuLu!

0 Likes
Shopify Staff
Shopify Staff
163 16 25

So glad to hear that worked for you, @BIASI. Happy it is all sorted for you now.

 

Let me know if you need anything further.

 

All the best!

Lulu

Lulu | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Click Accept as Solution 

0 Likes