GemPages inserting it's own JSON-LD??

Solved
KieranR
Shopify Partner
254 21 75

Hey all and @Seal_Commerce 

There's an issue with JSON-LD appearing in my GemPages

It seems to be inserted into all of the auto-generated product.gem-XXXXXXXX-template.liquid files: 

KieranR_0-1606176309649.png

I can't figure out how this (ld+json) is getting in there inside of what appears to be the "editor" and/or how to turn it off. 

This is a problem because I already have a good JSON-LD setup and this is causing duplication and is low-quality

I have logged a ticket with them, but thought I'd post here in case anyone has come accross the same issue.

Any ideas?

Full time Shopify SEO guy, based in NZ. Sometimes freelance outside the 9-5.
0 Likes
James_Gems
Shopify Partner
3 1 0

Hi my friend,

I understand that you want to disable json product data on your product page, am I correct?

You could try put this code into your theme.liquid, before close body tag </body>, and try to publish your template from GemPages editor again

<script>
window.gfDisableSchema = true
</script>

 

I hope this tip will help you to solve this query, my friend.

Please let us know how it goes.

0 Likes
KieranR
Shopify Partner
254 21 75

Just following up - thanks for looking at this and for the suggestion. Not an ideal fix honestly because the suggested fix is a client-side JS, so the JSON-LD product data is still there in source.

Product schema canconflicts can cause issues across several touchpoints like FB ads, GMC and SEO. There's no guarantee that all crawlers will even look at JS rendered DOM for product schema situations. So being able to control exactly what gets output in source can become quite critical, especially at scale.

GEMpages should be asking permission in an admin settings area like "Insert JSON-LD product schema into product pages" [YES/NO]

Or failing that, there should be a way to disable JSON-LD from being inserted in the first place (in the source not via JS). I can edit the liquid templates that GEM generates for each custom page to delete the schema, but GEM will just over-write when someone else hits publish! Not ideal.

Full time Shopify SEO guy, based in NZ. Sometimes freelance outside the 9-5.
0 Likes

This is an accepted solution.

Hi @KieranR 

Thank you so much for letting us know your ideas.

We've released the feature that helps our merchants can disable "Global Rich Snippets" like the screenshot below.

GemPages_Agents_0-1618458027688.png

To access these settings, you can click on Your Name & Your Shopify domain on the top right of GemPage Dashboard > Select Store Settings. 

Please try it and let us know how it goes. 

Looking forward to hearing from you, @KieranR 

 

If you find my reply helpful, please hit Like and Mark as Solution
Build high-converting stores with GemPages Page Builder
Get connected: Website | Youtube | Community | Partners | Help Center
KieranR
Shopify Partner
254 21 75

Awesome! Thanks @GemPages_Agents for sorting that! It works, seems to need "Publish" to be clicked on each page. 

Full time Shopify SEO guy, based in NZ. Sometimes freelance outside the 9-5.

Yeah, @KieranR 

I forgot this step. You are right, we need to publish the page again to have a new update.

Thanks for letting us know about that.

Best Regards,

If you find my reply helpful, please hit Like and Mark as Solution
Build high-converting stores with GemPages Page Builder
Get connected: Website | Youtube | Community | Partners | Help Center