There was a problem loading this app

Solved
madean
New Member
2 0 2

Hello,

I am getting error loading my Fondmart app 

cylosh
New Member
1 0 1

Same error, something changed to the API in the last few days that causes this

There was a problem loading this app

Please try opening or installing the app again.

dkdev
Tourist
3 0 1

I just encountered this error with our app also. Has anyone figured out what's going wrong?

_Andrew_
New Member
2 1 1

Hello, I'm having just the same issue with our app. Did someone figure out what was the API change these days?

Our app is not embedded in Shopify, and is public but is not published.

0 Likes
dkdev
Tourist
3 0 1

I'm not sure but it could be a change they made in April: https://shopify.dev/changelog/host-parameter-added-to-the-oauth-redirect-uri

We had not updated our OAuth code in quite a while, and after investigating found that our flow was not following the current documentation at https://shopify.dev/apps/auth

After updating our code to follow the docs, it is working again.

The lesson here is that you really have to keep your eye on the change logs. Especially for OAuth because the API is not versioned. https://shopify.dev/api/usage/versioning#versioned-vs-unversioned-apis

0 Likes
_Andrew_
New Member
2 1 1

This is an accepted solution.

I've found the reason why! They've changed the authorization URL from '.../admin/oauth/request_grant' to '.../admin/oauth/authorize' and that's it! That's it!

After the change, everything starts working again!