does_not_require_shipping error for digital product in custom android app, using buy-2.1.2.aar

Highlighted
New Member
1 0 0

Hi, I'm using buy-2.1.2.aar in my custom android app.

How to use checkout for digital product in my app?

At this moment I have an error:

{"errors":{"checkout":{"base":[{"code":"does_not_require_shipping","message":"You don't have any items that require shipping","options":{}}]}}}

 

if i set shipping_address = null

it will give an error:

{"errors":{"checkout":{"base":[{"code":"does_not_require_shipping","message":"You don't have any items that require shipping","options":{}}],"shipping_address":[{"code":"blank","message":"can't be blank","options":{}}]}}}

 

requests and responses are here: https://docs.google.com/document/d/1W8Rs2Ut0pbramDvWSDWrht-hnG-OmWTxhNzTG4wcoXc/edit?usp=sharing

0 Likes