Autoplay enabled but wont autoplay on blog page

Highlighted
Tourist
8 0 1

So the autoplay works in the blog post builder but in the post the video won't autoplay. I want it to autoplay so that it just goes and controls wont have to display. I'm hosting it on my site because i really dislike the vimeo and youtube iframes. It's silent, very unobtrusive, and only 1.2mb, just a product on a spinner. 

I'm unsure what I'm missing, i've had to imbed the video in the html as the markup language in the post builder only has an option for iframes.

Any advice please? Thank you. 

0 Likes
Highlighted
Shopify Staff
Shopify Staff
918 57 113

Hi there Josh!

Don here from Shopify!

Can you let us know a couple of things about how you have added this to your store so we can check out how you might proceed here?

If you can let us know the name of your current theme first (as it was downloaded from the theme store) that would be great.

It sounds like you have tried to add this video directly to your theme code, rather than by using an app or built-in feature; is that the case?

If you can confirm the theme being used for this store first we can see about how you would proceed from here next.

Regards,
Don

Don | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
Highlighted
Tourist
8 0 1

Hello Dan!

We have some customizations built on top of our theme, but I believe the base theme to be 'trademark'

It sounds like you have tried to add this video directly to your theme code, rather than by using an app or built-in feature; is that the case?

Nope - from the wysiwyg editor i just added the html to the page using the html editior (the button with the <> on it). I've largely left the theme files alone except messing with the slider for the homepage, which i doubt has anything to do with getting my pages and posts to autoplay how i'd like. 

Right now i have the .mp4 video hosted on the shopify cdn and the following code/attributes to put it in the page: 

<div style="text-align: center;">

<video autoplay="autoplay" width="100%" loop="loop" mute="mute" oncanplay="this.muted=true" playsinline="playsinline"> <source src="[insert video url here]?rel=&amp;amp:autoplay=1" type="video/mp4" /> </video>

</div>

I've had mixed success with this. I've kept the blog post im using for tests hidden, and when i render out a preview of it, half the time the video autoplays and half the time it doesnt. In safari that goes to nearly 100%, but chrome has been pushing code to make the autoplay conditions for videos more specific (as i understand it - totally new at this, im just the media guy).

Thanks for your help!

0 Likes
Highlighted
Shopify Staff
Shopify Staff
918 57 113

Hi again!

Don from Shopify once more. :)

Thanks for that extra info and clarification here.

I checked in with our own theme support specialists here who confirmed that we are unable to provide support for pages or posts created using the rich-text editor in the admin.

You mentioned that you are using the Trademark theme, which is created and supported by Maestrooo.

As such, you can try reaching out to the developers of this theme to see if they are able to provide any specific support for this issue.

Failing that, there are some Shopify Experts that specialise in smaller, theme-related tasks like HeyCarson or TaskHusky that you can check out.

Apologies that we can't do more to support here; it's just that code created in the RTE or by third-party developers lies outside of our support remit here so you would need to look elsewhere for assistance just on this particular issue. :)

All the best with this!

Regards,
Don

Don | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
Highlighted
Tourist
8 0 1

I changed mute="mute" to muted="muted" and it seems to have worked!

1 Like
Highlighted
Tourist
10 0 17

For anyone else who wants to add a self-hosted video to one of their pages: this is what I used for our site (running the Debut theme); just paste it into the html for the page. This plays automatically, loops, muted, full width of page. Upload the video to your "Settings/Files" and get the video link (https://cdn.shopify.com/s...mp4) from there.

 

<p><video muted="muted" autoplay="autoplay" loop="loop" playsinline="" width="100%">
<source src="https://cdn.shopify.com/s/files/.../.../.../.../files/MyVideo.mp4" type="video/mp4"></source>
</video></p>
7 Likes
Highlighted
Shopify Partner
1432 193 479

Edit: Nevermind, works both ways.

If my solution helped you, please like and accept as solution!
If you'd like to make any edits to your store, please send me a personal message and we can discuss what you'd like to accomplish :D
0 Likes
Highlighted
Shopify Partner
4 0 0

thank you

0 Likes
Highlighted
New Member
1 0 0

Thanks!!
Better then Shopify Support.

0 Likes