Collection Image Not Showing Up on Front-End Usning Supply Theme

Highlighted
New Member
1 0 1

I've uploaded/added collection image to back end (not code) but it's not showing up on front end. I'm using Supply theme

Screen Shot 2019-03-17 at 4.31.00 PM.png

 

 

Highlighted
Shopify Staff
Shopify Staff
754 42 155

Hey, @e_megan !

 

Katy here from Shopify. I hope all is great with you- and welcome to our Forum Community here.

 

This collection image here works as a featured collection image. It is designed to represent your collection - for example on the homepage of your store. If no image is added this will then default to the image of the first product in the collection.

 

I'd like to have a closer look into this with you, to make sure it is working as it should. If you have added and saved an image here, it should show on your Homepage when featuring this collection. Could you check on this for me under:

 

Admin > Online store > Themes > Customize theme > Featured collection > Add collection > Shad Jigs

 

If you do not see this here, do please try clearing your browser cache to see if this helps. 

If not, do let me know and I can certainly take a look. We do also recommend using square images for these featured images (more info on this here).

 

If however, you would like this image to appear on your collection page itself (like a banner for example) this is something that our Theme specialists can set up for you.  This is included in your free design time as part of our Design Policy. If this is more like what you are after, do let me know and I can help to get this set up for you.

 

 

Cheers,
Katy

 

Highlighted
New Member
1 0 0

Hi,

 

The image was showing in my collections section originally until I tried to add google tags to my pages this morning and now its gone. However, I reversed the theme back to the original but it still is not responsive, please is there something I'm missing?

 

Thanks

Ophir


@Katy wrote:

Hey, @e_megan !

 

Katy here from Shopify. I hope all is great with you- and welcome to our Forum Community here.

 

This collection image here works as a featured collection image. It is designed to represent your collection - for example on the homepage of your store. If no image is added this will then default to the image of the first product in the collection.

 

I'd like to have a closer look into this with you, to make sure it is working as it should. If you have added and saved an image here, it should show on your Homepage when featuring this collection. Could you check on this for me under:

 

Admin > Online store > Themes > Customize theme > Featured collection > Add collection > Shad Jigs

 

If you do not see this here, do please try clearing your browser cache to see if this helps. 

If not, do let me know and I can certainly take a look. We do also recommend using square images for these featured images (more info on this here).

 

If however, you would like this image to appear on your collection page itself (like a banner for example) this is something that our Theme specialists can set up for you.  This is included in your free design time as part of our Design Policy. If this is more like what you are after, do let me know and I can help to get this set up for you.

 

 

Cheers,
Katy

 


 

0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 155

Hi, @ophir !

 

Thanks so much for joining in here and welcome!

 

I am afraid that without a link to your store or screenshot it is a little difficult for me to test this out with you.

 

Would you be able to pass me this information, along with the following:

 

  • Details of the customizations you had made and where you had done so.
  • If you notice any error messages
  • What image shows in place of your featured image

If you have undone any edits that you had applied, it may be a case that you too will need to clear your browser cache. Info on how to do so can be found here

 

Do let me know how this goes or provide the above info if unsuccessful, and I can then best help you out.

 

Cheers,
Katy

0 Likes
Highlighted
New Member
2 0 0

Hi Katy,

If I may jump on this thread- I found it while googling for an answer. I would indeed like the collection image to appear on the collection page. How can I get this done please? Thanks

0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 155

Hey, @LindsayE22 !

 

Thanks so much for joining in and welcome to our Community. For sure you can join in here!

 

That is interesting - have you been able to cross-check with the above steps? For example, there may be a couple of things preventing this from being displayed. Could you let me know:

 

  • The name of your theme
  • If you have made any recent customizations to your theme?
  • If you notice any error messages
  • What, if any, image shows in place of your collection image?

If the previous workarounds suggested do not do the trick, we will likely need to examine this that bit further. To do so, we will need to verify your details securely. If you could please contact our support team via this link here we can then access your account and look into this with you.

 

Cheers,

Katy

0 Likes
Highlighted
New Member
1 0 0

Hi Katy,

I need some help here about the same topic. the collection image isn't displayed when i preview at the front end. what to do? 

thanks.

0 Likes
Highlighted
New Member
2 0 0

Hi Katy,

 

I also faced same issue, which the product images not show up at collection page, but hoover it, the product image can be seen. 

Currently i using Minimal theme, and did some customization to my store by googling solution. 

I not sure which code is going wrong, as all other things seem fine except this. Hope you can help. 

* This is my store url https://thebloomstudio.com.my/ and password tbs123

Kathryne_YY_0-1596774087319.png

 

0 Likes
Highlighted
New Member
1 0 0

Hi,

First time post having joined Shopify recently. 

I'm having the same issue, as the other people above. Have uploaded an image which does appear on the front page as part of the collection list but when you go into the collection that image is not appearing.

Not sure if it's relevant or not but in looking at other posts around collection images there is a few mentions of .collection-hero within the themes.scss.liquid file. I have no such coding within my themes files suggesting that there is no provision for a collection page header image.

Regardless, I'd love to know if anyone has found a solution to this yet.

Thanks,

URL to my WIP site is: www.soothesenses.com

0 Likes
Highlighted
New Member
1 0 0

Same here,

we have three categories and the image of only the first one is showing and responding to changes (partially). The other two categories does have the very same image, which is not showing (and is not covered or deactivated, as the developer tools reveal).

Beside that: when saving the category's png image it's shown with correct alpha channel. After reloading the category's configuration backend it is shown with black instead of transparent background. And that's the way the one image is shown in the frontend: with black background.

Do You have developed a solution to this issue?

Regards
-Robert.

0 Likes