Deleted Menu Link still on some pages

Highlighted
New Member
2 0 0

So I deleted an old category we are no longer selling items in and it is still appearing in our main menu on some pages. Stays on home page and a few others but gone like it should be on other. I have cleared my broser cache and restarted. and I deleted them a few days ago and still cant get rid of them... any ideas?

0 Likes
Highlighted
Shopify Staff
Shopify Staff
510 0 85

Hey, Greg, 

I'm Ann, from the team here at Shopify :)

That's strange for sure! Its possible that this is a cache issue with your storefront, in which case, I can move this conversation to email and look into clearing that for you. 

However, before we do that, can you tell me what menu item keeps reappearing so I can take a look on my end? Additionally, have you tested this in other browsers?

Let me know! 

Have a great one,
Ann

Ann | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Highlighted
New Member
2 0 0

Hi Ann....

Looks like it has fianlly gone away...only took two days...

0 Likes
Highlighted
Shopify Staff
Shopify Staff
510 0 85

Hey, Greg, 

Thanks for keeping me in the loop about this! If you see it happen again, let me know and we take a closer look, but happy to hear it's resolved :)

Have a great one,
Ann

Ann | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
Highlighted
New Member
1 0 0

Hi Ann! 

I have this same issue. After I created a menu item (an external link), then I deleted it, and even though in the admin panel everything looks good, without the menu item, when I go the site it still shows the menu item. Don't know if its a cache thing. 

https://www.keepitsimplesurf.co.za/

0 Likes
Highlighted
New Member
5 0 0

I'm having this same problem. I had two self-created 'Main Menu' items pointing to 'Shipping & Handling', and, 'Contact Us' pages. My 'Main Menu' was getting crowded so to move a few things out I created the same two menu items in the 'Footer Menu', and deleted them from the main menu. The 'Footer Menu' items function fine and direct to the proper associated pages, but the two deleted 'Main Menu' items remain on my pages even though they are no longer present in my admin navigation main menu settings. Its the strangest thing.

0 Likes
Highlighted
New Member
5 0 0

Disregard, they have finally vanished after a period of time.

0 Likes